Sourav Poddar<sourav.poddar@xxxxxx> writes:Looping in Vaibhav Bedia for ocmcram..
Hi Kevin,Can you please ask the AM33xx folks how (and why) this is being used?
On Friday 05 April 2013 11:10 PM, Kevin Hilman wrote:
Sourav Poddar<sourav.poddar@xxxxxx> writes:I was working on your above suggestions, but realised there is not
With dt boot, uart wakeup after suspend is non functional while usingRather than make these special checks inside the driver's runtime PM
"no_console_suspend" in the bootargs. With "no_console_suspend" used, we
should prevent the runtime suspend of the uart port which is getting used
as an console.
Cc: Santosh Shilimkar<santosh.shilimkar@xxxxxx>
Cc: Felipe Balbi<balbi@xxxxxx>
Cc: Rajendra nayak<rnayak@xxxxxx>
Tested on omap5430evm, omap4430sdp.
Signed-off-by: Sourav Poddar<sourav.poddar@xxxxxx>
callbacks, you should just disable runtime PM (pm_runtime_disable())
Then, this should be broken into 2 patches.
1) serial core: add the '->is_console' flag. (nit on naming: don't call
it port_is_console, since the struct is already a uart_port)
2) In the OMAP UART driver's ->prepare callback, check the is_console flag
and pm_runtime_disable() accordingly (then pm_runtime_enable() in
the drivers's ->complete callback.
Kevin
only console
uart which has the requirement of keeping the clocks enabled while going on
suspend.
If you see arch/arm/boot/dts/am33xx.dtsi, there is a ocmcram which has
"no_idle_on_suspend" property used.
I don't see/find a driver for this device in mainline, so without a
driver this flag will not be used.
[Kevin]: Yes, will do that.ocmcram: ocmcram@40300000 {Could you also have a look at Russell's suggestion for getting rid of
compatible = "ti,am3352-ocmcram";
reg =<0x40300000 0x10000>;
ti,hwmods = "ocmcram";
ti,no_idle_on_suspend;
};
This property gets checked in omap_device file and correspondingly
od->flags is set.
Based on your above inputs, the patches which I cooked up is
inlined[1]. Though, the below
patches works fine for uart case. The patches will effect ocmcram case
and I am inling them
"just for discussion".
the 'is_console' flag.
Thanks,~Sourav
Kevin