Re: [PATCH 03/32] dmaengine: ste_dma40: Use the BIT macro toreplace ugly '(1 << x)'s

From: Russell King - ARM Linux
Date: Thu Apr 18 2013 - 06:44:04 EST


On Thu, Apr 18, 2013 at 11:11:45AM +0100, Lee Jones wrote:
> The aim is to make the code that little more readable.

Maybe we should also invent the MULT() macro too, because a * b is just
too ugly as well? Maybe ADD(), SUB() and DIV() macros as well... Think
of all those extra parens you could use! :)

> @@ -1448,7 +1448,7 @@ static u32 d40_residue(struct d40_chan *d40c)
> >> D40_SREG_ELEM_PHY_ECNT_POS;
> }
>
> - return num_elt * (1 << d40c->dma_cfg.dst_info.data_width);
> + return num_elt * BIT(d40c->dma_cfg.dst_info.data_width);

This should be:
return num_elt << d40c->dma_cfg.dst_info.data_width;
--
To unsubscribe from this list: send the line "unsubscribe linux-kernel" in
the body of a message to majordomo@xxxxxxxxxxxxxxx
More majordomo info at http://vger.kernel.org/majordomo-info.html
Please read the FAQ at http://www.tux.org/lkml/