I just want to make the ecc_strength/ecc_size more coupled for the nand_flash_dev{}.
A bit late on this one, but is there a good reason this wasn't just 2
separate 16-bit fields? We already have a few, and I don't see why
this couldn't be the same.
Do this type of macro could be accepted by the kernel?Signed-off-by: Huang Shijie<b32955@xxxxxxxxxxxxx>We could redefine this:
---
include/linux/mtd/nand.h | 10 ++++++++++
1 files changed, 10 insertions(+), 0 deletions(-)
diff --git a/include/linux/mtd/nand.h b/include/linux/mtd/nand.h
index 063e517..f4c7777 100644
--- a/include/linux/mtd/nand.h
+++ b/include/linux/mtd/nand.h
@@ -624,6 +624,10 @@ struct nand_chip {
{ .name = (nm), {{ .dev_id = (devid) }}, .chipsize = (chipsz), \
.options = (opts) }
+#define NAND_ECC_INFO(strength, size) (((strength)<< 16) | (size))
#define NAND_ECC_INFO(strength, size) .ecc_strength = (strength),
.ecc_size = (size)