On 6/11/13 3:59 AM, Maxim Patlasov wrote:
- if (mode & FALLOC_FL_PUNCH_HOLE) {
+ if (lock_inode)
mutex_lock(&inode->i_mutex);
+ if (mode & FALLOC_FL_PUNCH_HOLE)
fuse_set_nowrite(inode);
- }
Just for clarity, can you make the condition to check FALLOC_FL_PUNCH_HOLE and call to fuse_set_nowrite() nested within the larger if (lock_inode) { .. } block? fuse_set_nowrite() should not be called without i_mutex acquired. The current style of calling mutex_lock() and fuse_set_nowrite() in separate conditions can potentially cause bugs in the future if they were to get re-ordered due to some unrelated patch. Nesting them makes the relation more explicit and clear.