On Tue, Dec 03, 2013 at 12:13:24PM +0530, Keerthy wrote:
+static int tps65218_ldo1_dcdc3_vsel_to_uv(unsigned int vsel)Use regulator_map_voltage_linear_range() (and similarly for most of the
+{
+ int uV = 0;
+
+ if (vsel <= 26)
+ uV = vsel * 25000 + 900000;
+ else
+ uV = (vsel - 26) * 50000 + 1550000;
+
+ return uV;
+}
other functions).
Okay.+static const struct of_device_id tps65218_of_match[] = {Indexing into another array by magic number like this is both error
+ TPS65218_OF_MATCH("ti,tps65218-dcdc1", tps65218_pmic_regs[0]),
+ TPS65218_OF_MATCH("ti,tps65218-dcdc2", tps65218_pmic_regs[1]),
+ TPS65218_OF_MATCH("ti,tps65218-dcdc3", tps65218_pmic_regs[2]),
+ TPS65218_OF_MATCH("ti,tps65218-dcdc4", tps65218_pmic_regs[3]),
+ TPS65218_OF_MATCH("ti,tps65218-dcdc5", tps65218_pmic_regs[4]),
+ TPS65218_OF_MATCH("ti,tps65218-dcdc6", tps65218_pmic_regs[5]),
+ TPS65218_OF_MATCH("ti,tps65218-ldo1", tps65218_pmic_regs[6]),
+};
+MODULE_DEVICE_TABLE(of, tps65218_of_match);
prone and hard to read. Either use defined constants or individual
variables for the things being referenced.