[PATCH 4/4] Staging: comedi: addi-data: do not initialize statics to 0 in hwdrv_apci035.c

From: Chase Southwood
Date: Sun Feb 16 2014 - 03:41:43 EST


This patch for hwdrv_apci035.c removes a zero initialization from two
static variables. Static variables are initialized to zero by default,
so doing so explicitly is not necessary.

Signed-off-by: Chase Southwood <chase.southwood@xxxxxxxxx>
---
I purposely made this patch the last in the series, because while it is
technically true that static variables need not be initialized to zero,
and checkpatch doesn't much like the practice, I didn't know if, for
readability's sake, you wanted these to stay in as-is. Since this is the
last patch, feel free to drop it if you don't like it.

drivers/staging/comedi/drivers/addi-data/hwdrv_apci035.c | 4 ++--
1 file changed, 2 insertions(+), 2 deletions(-)

diff --git a/drivers/staging/comedi/drivers/addi-data/hwdrv_apci035.c b/drivers/staging/comedi/drivers/addi-data/hwdrv_apci035.c
index f02b714..10e02e5 100644
--- a/drivers/staging/comedi/drivers/addi-data/hwdrv_apci035.c
+++ b/drivers/staging/comedi/drivers/addi-data/hwdrv_apci035.c
@@ -106,8 +106,8 @@ static struct comedi_lrange range_apci035_ai = {
}
};

-static int i_WatchdogNbr = 0;
-static int i_Temp = 0;
+static int i_WatchdogNbr;
+static int i_Temp;
static int i_Flag = 1;
/*
+----------------------------------------------------------------------------+
--
1.8.5.3

--
To unsubscribe from this list: send the line "unsubscribe linux-kernel" in
the body of a message to majordomo@xxxxxxxxxxxxxxx
More majordomo info at http://vger.kernel.org/majordomo-info.html
Please read the FAQ at http://www.tux.org/lkml/