[RFC Patch v1 0/6] Miscellaneous improvements for ACPI

From: Jiang Liu
Date: Mon Feb 17 2014 - 00:00:40 EST


Hi,
This is a miscellaneous patch set to improve ACPI code. due to
resource limitation, I can't find hardware to test all patches.
So appreciate any help to these patches.

Thanks!
Gerry

Jiang Liu (6):
acpi_pad: simplify notify handler by using acpi_drv_ops->notify
ACPI: rename acpi_evaluate_hotplug_ost to acpi_evaluate_ost for reuse
acpi_pad: use acpi_evaluate_pad() to replace open-coded version
xen, acpi_pad: use acpi_evaluate_pad() to replace open-coded version
acpi_processor: use acpi_evaluate_pad() to replace open-coded version
ACPI: use device name LNXSYBUS.xx for ACPI \_SB and \_TZ objects

drivers/acpi/acpi_pad.c | 49 ++++++++------------------------------
drivers/acpi/processor_perflib.c | 14 +++--------
drivers/acpi/scan.c | 20 ++++++++++++++--
drivers/acpi/utils.c | 14 ++++-------
drivers/xen/xen-acpi-pad.c | 26 ++++++--------------
include/acpi/acpi_bus.h | 10 +++++++-
6 files changed, 51 insertions(+), 82 deletions(-)

--
1.7.10.4

--
To unsubscribe from this list: send the line "unsubscribe linux-kernel" in
the body of a message to majordomo@xxxxxxxxxxxxxxx
More majordomo info at http://vger.kernel.org/majordomo-info.html
Please read the FAQ at http://www.tux.org/lkml/