Re: [RFC Patch v1 2/6] ACPI: rename acpi_evaluate_hotplug_ost to acpi_evaluate_ost for reuse

From: Rafael J. Wysocki
Date: Mon Feb 17 2014 - 19:52:09 EST


On Monday, February 17, 2014 01:02:49 PM Jiang Liu wrote:
> Rename acpi_evaluate_hotplug_ost() to acpi_evaluate_ost() for later resue.
>
> Signed-off-by: Jiang Liu <jiang.liu@xxxxxxxxxxxxxxx>
> ---
> drivers/acpi/utils.c | 14 ++++----------
> include/acpi/acpi_bus.h | 10 +++++++++-
> 2 files changed, 13 insertions(+), 11 deletions(-)
>
> diff --git a/drivers/acpi/utils.c b/drivers/acpi/utils.c
> index 85e3b61..19d0169 100644
> --- a/drivers/acpi/utils.c
> +++ b/drivers/acpi/utils.c
> @@ -433,17 +433,15 @@ EXPORT_SYMBOL(acpi_get_physical_device_location);
> * When the platform does not support _OST, this function has no effect.
> */
> acpi_status
> -acpi_evaluate_hotplug_ost(acpi_handle handle, u32 source_event,
> - u32 status_code, struct acpi_buffer *status_buf)

There are users of this, what about updating them?

> +acpi_evaluate_ost(acpi_handle handle, u32 source_event, u32 status_code,
> + struct acpi_buffer *status_buf)
> {
> -#ifdef ACPI_HOTPLUG_OST
> union acpi_object params[3] = {
> {.type = ACPI_TYPE_INTEGER,},
> {.type = ACPI_TYPE_INTEGER,},
> {.type = ACPI_TYPE_BUFFER,}
> };
> struct acpi_object_list arg_list = {3, params};
> - acpi_status status;
>
> params[0].integer.value = source_event;
> params[1].integer.value = status_code;
> @@ -455,13 +453,9 @@ acpi_evaluate_hotplug_ost(acpi_handle handle, u32 source_event,
> params[2].buffer.length = 0;
> }
>
> - status = acpi_evaluate_object(handle, "_OST", &arg_list, NULL);
> - return status;
> -#else
> - return AE_OK;
> -#endif
> + return acpi_evaluate_object(handle, "_OST", &arg_list, NULL);
> }
> -EXPORT_SYMBOL(acpi_evaluate_hotplug_ost);
> +EXPORT_SYMBOL(acpi_evaluate_ost);
>
> /**
> * acpi_handle_printk: Print message with ACPI prefix and object path
> diff --git a/include/acpi/acpi_bus.h b/include/acpi/acpi_bus.h
> index 8256eb4..adef502 100644
> --- a/include/acpi/acpi_bus.h
> +++ b/include/acpi/acpi_bus.h
> @@ -49,8 +49,16 @@ acpi_evaluate_reference(acpi_handle handle,
> struct acpi_object_list *arguments,
> struct acpi_handle_list *list);
> acpi_status
> +acpi_evaluate_ost(acpi_handle handle, u32 source_event, u32 status_code,
> + struct acpi_buffer *status_buf);
> +#ifdef ACPI_HOTPLUG_OST
> +#define acpi_evaluate_hotplug_ost acpi_evaluate_ost
> +#else
> +static inline acpi_status
> acpi_evaluate_hotplug_ost(acpi_handle handle, u32 source_event,
> - u32 status_code, struct acpi_buffer *status_buf);
> + u32 status_code, struct acpi_buffer *status_buf)
> +{ return AE_OK; }
> +#endif
>
> acpi_status
> acpi_get_physical_device_location(acpi_handle handle, struct acpi_pld_info **pld);
>

--
I speak only for myself.
Rafael J. Wysocki, Intel Open Source Technology Center.
--
To unsubscribe from this list: send the line "unsubscribe linux-kernel" in
the body of a message to majordomo@xxxxxxxxxxxxxxx
More majordomo info at http://vger.kernel.org/majordomo-info.html
Please read the FAQ at http://www.tux.org/lkml/