Re: [PATCH v2] sysfs: fix namespace refcnt leak

From: Tejun Heo
Date: Fri Feb 21 2014 - 05:13:12 EST


On Fri, Feb 21, 2014 at 10:55:55AM +0800, Li Zefan wrote:
> As mount() and kill_sb() is not a one-to-one match, we shoudn't get
> ns refcnt unconditionally in sysfs_mount(), and instead we should
> get the refcnt only when kernfs_mount() allocated a new superblock.
>
> v2:
> - Changed the name of the new argument, suggested by Tejun.
> - Made the argument optional, suggested by Tejun.
>
> Signed-off-by: Li Zefan <lizefan@xxxxxxxxxx>
...
> @@ -132,6 +132,7 @@ const void *kernfs_super_ns(struct super_block *sb)
> * @flags: mount flags specified for the mount
> * @root: kernfs_root of the hierarchy being mounted
> * @ns: optional namespace tag of the mount
> + * @new_sb_created: tell the caller if we allocated a new superblock
> *
> * This is to be called from each kernfs user's file_system_type->mount()
> * implementation, which should pass through the specified @fs_type and
> @@ -141,7 +142,8 @@ const void *kernfs_super_ns(struct super_block *sb)
> * The return value can be passed to the vfs layer verbatim.
> */
> struct dentry *kernfs_mount_ns(struct file_system_type *fs_type, int flags,
> - struct kernfs_root *root, const void *ns)
> + struct kernfs_root *root, const void *ns,
> + bool *new_sb_created)

Oops, just one more thing. Let's please put @new_sb_created before
@ns; otherwise, kernfs_mount_ns() and kernfs_mount() become really
confusing as we end up omitting the second-to-last param for the
latter instead of the last.

Other than that,

Reviewed-by: Tejun Heo <tj@xxxxxxxxxx>

Thanks.

--
tejun
--
To unsubscribe from this list: send the line "unsubscribe linux-kernel" in
the body of a message to majordomo@xxxxxxxxxxxxxxx
More majordomo info at http://vger.kernel.org/majordomo-info.html
Please read the FAQ at http://www.tux.org/lkml/