[PATCH v2 0/4] ntb: Use pci_enable_msix_range() instead of pci_enable_msix()

From: Alexander Gordeev
Date: Fri Feb 21 2014 - 10:47:44 EST


Hi Jon,

This is an attempt to make ntb_setup_msix() more readable ( to me :) )

The idea is to get rid of confusing branching between SNB and BWD
and split MSI-X ininialization into ntb_setup_bwd_msix() and
ntb_setup_snb_msix() - both small and straight.

Cc: Jon Mason <jon.mason@xxxxxxxxx>
Cc: linux-pci@xxxxxxxxxxxxxxx

Alexander Gordeev (4):
ntb: Fix leakage of ntb_device::msix_entries[] array
ntb: Use pci_msix_vec_count() to obtain number of MSI-Xs
ntb: Split ntb_setup_msix() into separate BWD/SNB routines
ntb: Use pci_enable_msix_range() instead of pci_enable_msix()

drivers/ntb/ntb_hw.c | 174 +++++++++++++++++++++++++++++---------------------
drivers/ntb/ntb_hw.h | 2 -
2 files changed, 100 insertions(+), 76 deletions(-)

--
1.7.7.6

--
To unsubscribe from this list: send the line "unsubscribe linux-kernel" in
the body of a message to majordomo@xxxxxxxxxxxxxxx
More majordomo info at http://vger.kernel.org/majordomo-info.html
Please read the FAQ at http://www.tux.org/lkml/