On Sat, Mar 1, 2014 at 9:14 PM, Ohad Ben-Cohen <ohad@xxxxxxxxxx> wrote:
On Mon, Feb 10, 2014 at 9:14 PM, Suman Anna <s-anna@xxxxxx> wrote:
On 02/07/2014 04:49 PM, Bjorn Andersson wrote:
It seems to be standard practice to pass the error value back to the
consumer, so you should
return ERR_PTR(ret); here instead of the NULL...
I have modelled the return values in this function based on the return
values in the existing hwspin_lock_request interfaces. I would need to
change those functions as well.
Ohad,
Do you have any objections to the return code convention change?
Unless strictly needed, I prefer we don't switch to the ERR_PTR code
convention, as it reduces code readability and increases chances of
user bugs.
In our case, switching to ERR_PTR and friends seems only to optimize a
few error paths, and I'm not sure it's a big win over simplicity.
When introducing the ability to reference a hwspin lock via a phandle
in device tree it makes a big difference to be able to differ between
the case of "initialization failed" or "device not yet probed"; so
that the client knows if it should fail or retry later.