Re: [PATCH v10 1/3] mmc: sdhci-msm: Qualcomm SDHCI binding documentation

From: Georgi Djakov
Date: Thu Mar 06 2014 - 12:46:04 EST


On 03/05/2014 08:56 AM, Rob Herring wrote:
On Tue, Mar 4, 2014 at 1:27 PM, Georgi Djakov <gdjakov@xxxxxxxxxx> wrote:
[..]
+Required properties:
+- compatible: Should contain "qcom,sdhci-msm-v4".
+- reg: Base address and length of the register set listed in reg-names.
+- reg-names: Should contain the following:
+ "hc_mem" - Host controller register map
+ "core_mem" - SD Core register map

reg-names should not be required and the order specified by the binding.


Ok, Rob! Thanks!

+- interrupts: Should contain an interrupt-specifiers for the interrupts listed in interrupt-names.
+- interrupt-names: Should contain the following:
+ "hc_irq" - Host controller interrupt
+ "pwr_irq" - PMIC interrupt

Same for interrupt-names.


Ok.

+- vdd-supply: Phandle to the regulator for the vdd (core voltage) supply.
+- vdd-io-supply: Phandle to the regulator for the vdd-io (i/o voltage) supply.
+- pinctrl-names: Should contain only one value - "default".
+- pinctrl-0: Should specify pin control groups used for this controller.
+- clocks: A list of phandle + clock-specifier pairs for the clocks listed in clock-names.
+- clock-names: Should contain the following:
+ "iface" - Main peripheral bus clock (PCLK/HCLK - AHB Bus clock) (required)
+ "core" - SDC MMC clock (MCLK) (required)
+ "bus" - SDCC bus voter clock (optional)
+
+Example:
+
+ sdhc_1: sdhci@f9824900 {
+ compatible = "qcom,sdhci-msm-v4";
+ reg = <0xf9824900 0x11c>, <0xf9824000 0x800>;

Are there cases where these are really in a different 4KB range? If
not, this should just be 1 range.


Thanks for your suggestion. This sounds reasonable, but in this case,
I think that it might be better leaving the memory regions separated as it will help avoiding code duplication. I am using the generic sdhci_pltfm_init(), which assumes that the first resource is the HC iomem and configures the host. If I merge them, the HC address will be offset and this might require duplicating some of the init code.
Is it acceptable to leave it this way?

BR,
Georgi
--
To unsubscribe from this list: send the line "unsubscribe linux-kernel" in
the body of a message to majordomo@xxxxxxxxxxxxxxx
More majordomo info at http://vger.kernel.org/majordomo-info.html
Please read the FAQ at http://www.tux.org/lkml/