Sorry...I'm not saying they are in the wrong order, I'm just asking. Who wroteSorry for the delay. It was a hectic week last week.ok i change the order
As promised:
This patch adds ST Keyscan driver to use the keypad hw a subsetAre you sure these are in the correct order?
of ST boards provide. Specific board setup will be put in the
given dt.
Signed-off-by: Giuseppe Condorelli<giuseppe.condorelli@xxxxxx>
Signed-off-by: Gabriel Fernandez<gabriel.fernandez@xxxxxx>
the patch? Has it changed since?
After discussing internally with st "st,sti-keyscan" is betterThat sounds more generic, but if it's not documented as such, thenyou want to refer to "debounce-interval" ?+- linux,keymap: The keymap for keys as described in the binding documentI'm sure there will be a shared binding for de-bounce.
+ devicetree/bindings/input/matrix-keymap.txt.
+
+- keypad,num-rows: Number of row lines connected to the keypad controller.
+
+- keypad,num-columns: Number of column lines connected to the keypad
+ controller.
+
+- st,debounce_us: Debouncing interval time in microseconds
If not, there certainly should be.
please consider doing so.
So st,stix-keypad, or st,sti4x-keypad?+Example:for my knowledge this IP is the same for stixxxx platform.
+
+keyscan: keyscan@fe4b0000 {
+ compatible = "st,keypad";
Is there any way we can make this more specific to _this_ IP?
I'm just thinking about future proofing the architecture. What if ST
released stj which has a different keypad IP?
okThat's not quite what I meant, I mean can't ST_KEY_MAXKEYS be morei 'll rename 'num_out_pads' into 'n_rows' and 'num_in_pads' into+struct keyscan_priv {Seems odd to limit this. Can't the information come from DT
+ void __iomem *base;
+ int irq;
+ struct clk *clk;
+ struct input_dev *input_dev;
+ struct keypad_platform_data *config;
+ unsigned int last_state;
+ u32 keycodes[ST_KEYSCAN_MAXKEYS];
i.e. keypad,num-rows and keypad,num-columns?
'n_cols'
dynamic and be obtained from (keypad,num-rows * keypad,num-columns)?