Re: [PATCH 00/12] scsi/NCR5380: fix debugging macros and #include structure

From: Finn Thain
Date: Tue Mar 18 2014 - 08:01:12 EST

On Mon, 17 Mar 2014, Joe Perches wrote:

> My preference would be to change dprintk to scsi_dbg

Can you be more specific? I gather you're not referring to the debugging
routines in include/scsi/scsi_dbg.h as they aren't equivalent.

Is it the name "dprintk" you object to?

I went looking in drivers/scsi/ for some kind of naming convention for a
conditional printk. There are some other variations on the theme (DEBUG,
PDEBUG, PERROR, etc) but dprintk() seems to be the most popular.

To unsubscribe from this list: send the line "unsubscribe linux-kernel" in
the body of a message to majordomo@xxxxxxxxxxxxxxx
More majordomo info at
Please read the FAQ at