RE: [RFC PATCH] ftrace function-graph: print the function name on all } lines
From: Elliott, Robert (Server Storage)
Date: Mon May 05 2014 - 15:22:35 EST
> From: Steven Rostedt [mailto:rostedt@xxxxxxxxxxx]
> ...
> Yes it is too cluttered. Please make this a tracing option that is
> default off.
The TRACE_GRAPH_PRINT_xx macros exist in two places:
* trace.h has one set
* trace_functions_graph.c has redefinitions of them and adds
TRACE_GRAPH_PRINT_IRQS.
The new macro will only be used inside trace_functions_graph.c.
That is true of some of the others like TRACE_GRAPH_PRINT_OVERRUN,
so doesn't seem to be the guiding principle for separate sets.
Should the new one be added to both places, or should the
duplicate definitions in trace_functions_graph.c be removed?
trace_functions_graph.c:
#include "trace.h"
...
/* Flag options */
#define TRACE_GRAPH_PRINT_OVERRUN 0x1
#define TRACE_GRAPH_PRINT_CPU 0x2
#define TRACE_GRAPH_PRINT_OVERHEAD 0x4
#define TRACE_GRAPH_PRINT_PROC 0x8
#define TRACE_GRAPH_PRINT_DURATION 0x10
#define TRACE_GRAPH_PRINT_ABS_TIME 0x20
#define TRACE_GRAPH_PRINT_IRQS 0x40
#define TRACE_GRAPH_PRINT_TAIL 0x80 /* <-- new */
trace.h:
/* Flag options */
#define TRACE_GRAPH_PRINT_OVERRUN 0x1
#define TRACE_GRAPH_PRINT_CPU 0x2
#define TRACE_GRAPH_PRINT_OVERHEAD 0x4
#define TRACE_GRAPH_PRINT_PROC 0x8
#define TRACE_GRAPH_PRINT_DURATION 0x10
#define TRACE_GRAPH_PRINT_ABS_TIME 0x20
#define TRACE_GRAPH_PRINT_FILL_SHIFT 28
#define TRACE_GRAPH_PRINT_FILL_MASK (0x3 << TRACE_GRAPH_PRINT_FILL_SHIFT)
---
Rob Elliott HP Server Storage
--
To unsubscribe from this list: send the line "unsubscribe linux-kernel" in
the body of a message to majordomo@xxxxxxxxxxxxxxx
More majordomo info at http://vger.kernel.org/majordomo-info.html
Please read the FAQ at http://www.tux.org/lkml/