Re: Re: [PATCH] uprobes/x86: Rename arch_uprobe->def into ->dflt, minor comment updates
From: Oleg Nesterov
Date: Wed Jun 04 2014 - 12:40:43 EST
On 06/04, Masami Hiramatsu wrote:
> (2014/06/04 4:13), Oleg Nesterov wrote:
> > On 06/03, Ingo Molnar wrote:
> >> So exactly what do those fields do? If it's scratch register handling,
> >> would it be logical to name it arch_uprobe->scratch, or so?
> > Not only, ->fixups encodes other flags. and ->ilen is used by UPROBE_FIX_CALL.
> > arch_uprobe->def contains the arguments for default_xol_ops methods, currently
> > this handles everything except relative jmp/call insns.
> > So perhaps ->dflt is not that ugly in this case? I simply do not see anything
> > better. But again, I agree with any name in advance.
> Hmm, how about ->defparam ? :)
Fine with me ;)
Ingo, will you agree with s/def/defparam/ ?
To unsubscribe from this list: send the line "unsubscribe linux-kernel" in
the body of a message to majordomo@xxxxxxxxxxxxxxx
More majordomo info at http://vger.kernel.org/majordomo-info.html
Please read the FAQ at http://www.tux.org/lkml/