Re: [PATCH] Input: atmel_mxt_ts - simplify mxt_initialize a bit

From: Nick Dyer
Date: Thu Jul 24 2014 - 11:39:51 EST

On 23/07/14 22:50, Dmitry Torokhov wrote:
> I think having control flow with 2 goto/labels/flags is quite hard to read,
> this version is a bit more readable IMO.
> Signed-off-by: Dmitry Torokhov <dmitry.torokhov@xxxxxxxxx>

Yes, this looks much clearer to me. Although I can't see anything wrong
looking at it, I think I should probably regression test it for the
different failure paths before it is applied, I will bring it into my series.
To unsubscribe from this list: send the line "unsubscribe linux-kernel" in
the body of a message to majordomo@xxxxxxxxxxxxxxx
More majordomo info at
Please read the FAQ at