Re: [PATCH 00/15] atmel_mxt_ts - device tree, bootloader, etc

From: Stephen Warren
Date: Thu Jul 24 2014 - 17:19:19 EST

On 07/24/2014 07:47 AM, Nick Dyer wrote:
On 23/07/14 18:22, Stephen Warren wrote:
That didn't make any difference.

I also tried the tool interactively. the "Display raw (M)essages" option
never displayed anything, and the couple of self-tests I tried just
timed out. "Read (I)nfo block" did display some values that seemed like
they might be correct rather than random data.

Interestingly though, I did bisect the series and found "Input:
atmel_mxt_ts - use deep sleep mode when stopped" causes the problem. If
I apply the whole series and revert that one patch, the touchpad works
for mouse movement, but interestingly not for taps or physical clicks.

Could you dump out the config for me (when it's in the failed state)? This
can be done by running:

mxt-app [device] --save fail.xcfg

That command always experiences a timeout error, but still seems to dump something out. Is this timeout error an issue? I'm a little hesitant to modify the COMMSCONFIG settings until I know load/save are really working.

root@localhost:~/obp-utils# ./mxt-app -d i2c-dev:1-004b --save ~/mxt-save-no-movement.xml
Registered i2c-dev adapter:1 address:0x4b
Opening config file /root/mxt-save-no-movement.xml...
REPORTALL command issued

I've uploaded 2 logs to:
(note there's no directory indexing, so manually add the filenames below to the URL)


This is with the whole series applied. Neither mouse movement nor clicks works. I tried mxt-app --reset and it made no difference to the dump results.


This is with "Input: atmel_mxt_ts - use deep sleep mode when stopped" reverted; mouse movement works, but clicking doesn't.
To unsubscribe from this list: send the line "unsubscribe linux-kernel" in
the body of a message to majordomo@xxxxxxxxxxxxxxx
More majordomo info at
Please read the FAQ at