Re: [PATCH 2/4] aio: use the macro rather than the inline magic number

From: Gu Zheng
Date: Fri Jul 25 2014 - 02:06:59 EST


Hi Lei,
On 07/25/2014 11:13 AM, Ming Lei wrote:

> On Tue, Jul 22, 2014 at 9:54 PM, Jeff Moyer <jmoyer@xxxxxxxxxx> wrote:
>> Gu Zheng <guz.fnst@xxxxxxxxxxxxxx> writes:
>>
>>> Signed-off-by: Gu Zheng <guz.fnst@xxxxxxxxxxxxxx>
>>
>> Reviewed-by: Jeff Moyer <jmoyer@xxxxxxxxxx>
>>
>>> ---
>>> fs/aio.c | 2 +-
>>> 1 files changed, 1 insertions(+), 1 deletions(-)
>>>
>>> diff --git a/fs/aio.c b/fs/aio.c
>>> index ad35876..1dc6158 100644
>>> --- a/fs/aio.c
>>> +++ b/fs/aio.c
>>> @@ -201,7 +201,7 @@ static struct dentry *aio_mount(struct file_system_type *fs_type,
>>> static const struct dentry_operations ops = {
>>> .d_dname = simple_dname,
>>> };
>>> - return mount_pseudo(fs_type, "aio:", NULL, &ops, 0xa10a10a1);
>>> + return mount_pseudo(fs_type, "aio:", NULL, &ops, AIO_RING_MAGIC);
>
> IMO, it might be better to use a new macro like AIO_FS_MAGIC
> with same number here because the same magic number
> 0xa10a10a1 serves for two purposes.

Sounds reasonable, but I prefer a more common name like
AIO_MAGIC to serve two if we need.:)

Thanks,
Gu

>
> Thanks,
> .
>


--
To unsubscribe from this list: send the line "unsubscribe linux-kernel" in
the body of a message to majordomo@xxxxxxxxxxxxxxx
More majordomo info at http://vger.kernel.org/majordomo-info.html
Please read the FAQ at http://www.tux.org/lkml/