Re: [PATCH v2 1/3] init/main.c: Give init_task a canary

From: Chuck Ebbert
Date: Wed Sep 10 2014 - 03:27:07 EST


On Tue, 9 Sep 2014 10:42:27 +0100
Aaron Tomlin <atomlin@xxxxxxxxxx> wrote:

> +void task_stack_end_magic(struct task_struct *tsk)
> +{
> + unsigned long *stackend;
> +
> + stackend = end_of_stack(tsk);
> + *stackend = STACK_END_MAGIC; /* for overflow detection */
> +}
> +

For clarity this should probably be called set_task_stack_end_magic().

And has this been tested on parisc and metag, which use STACK_GROWSUP ?
I can't see how end_of_stack() as it's defined now could work on those archs.


--
To unsubscribe from this list: send the line "unsubscribe linux-kernel" in
the body of a message to majordomo@xxxxxxxxxxxxxxx
More majordomo info at http://vger.kernel.org/majordomo-info.html
Please read the FAQ at http://www.tux.org/lkml/