Re: [PATCH] PM: Add helper to mark last busy and autosuspend

From: Vinod Koul
Date: Tue Sep 16 2014 - 13:56:50 EST


On Tue, Sep 16, 2014 at 01:22:11PM -0400, Alan Stern wrote:
> On Tue, 16 Sep 2014, Vinod Koul wrote:
>
> > > > > What's the advantage? Removing a few bytes of source code? There will
> > > > > no change to the object code. (Not to mention that your patch didn't
> > > > > actually change _any_ of the places where both routines get called!)
> > > > Yes we didnt change users, as we need this for one of our drivers we are
> > > > trying to push.
> > >
> > > Why do you need it? Just change your driver to call
> > >
> > > pm_runtime_mark_last_busy(dev);
> > > pm_runtime_put_autosuspend(dev);
> > >
> > > instead of
> > >
> > > pm_runtime_last_busy_and_autosuspend(dev);
> > >
> > > Or create a subroutine in your driver to do this.
> > Well since this is common why not add a helper in framework!
>
> You said this was common, but you didn't change any of the other places
> these routines get used. I asked why and you didn't asnwer; all you
> said was that you needed it for one of your drivers.
I didnt say we wont change users either. If you do a quick search you would
see a good numbers of folks who are using above and also have their own
helpers.

> I then pointed out that you don't need it. You didn't asnwer.
Since we have lot of users as well as my driver which we have already posted
we would like this to be in framwork

> I asked what advantage this change brings. You didn't answer.
IMHO helpers like these should be part of framework rather than everyone
having their own versions!
Yes it doesnt change the object code at all, but will reduce LOC and driver
macros

Hope this explains your questions, Will come back witha a v2 with users
converted as well

--
~Vinod
--
To unsubscribe from this list: send the line "unsubscribe linux-kernel" in
the body of a message to majordomo@xxxxxxxxxxxxxxx
More majordomo info at http://vger.kernel.org/majordomo-info.html
Please read the FAQ at http://www.tux.org/lkml/