On Tuesday 23 September 2014 15:55:08 behanw@xxxxxxxxxxxxxxxxxx wrote:It's all good. It's not like you haven't saved me a tonne of time already! :)
--- a/drivers/mmc/host/sdhci-bcm-kona.cSorry for giving you trouble over such a simple patch (especially
+++ b/drivers/mmc/host/sdhci-bcm-kona.c
@@ -225,7 +225,7 @@ static struct sdhci_pltfm_data sdhci_pltfm_data_kona = {
SDHCI_QUIRK_CAP_CLOCK_BASE_BROKEN,
};
-static struct __initconst of_device_id sdhci_bcm_kona_of_match[] = {
+static struct of_device_id const sdhci_bcm_kona_of_match[] = {
{ .compatible = "brcm,kona-sdhci"},
{ .compatible = "bcm,kona-sdhci"}, /* deprecated name */
{}
one that I have acked already), but I just noticed that this is
not following the common style we use in the kernel.
Almost everywhere in Linux, we useTrue enough. I put the const where I did to be in keeping with the intent of __initconst, making the array const instead of the contained type.
static const struct of_device_id sdhci_bcm_kona_of_match[] = {
not
static struct of_device_id const sdhci_bcm_kona_of_match[] = {
AFAICT they behave in identical ways,Indeed. For C in both cases the resulting array of struct of_device_id ends up in .rodata, so functionally equivalent.
but the first one seemsNo worries. Happy to post a v3.
easier to read for someone familiar with kernel code.