Re: [PATCH v1 5/5] driver-core: add driver asynchronous probe support

From: Luis R. Rodriguez
Date: Mon Sep 29 2014 - 18:10:50 EST

On Mon, Sep 29, 2014 at 2:59 PM, Greg KH <gregkh@xxxxxxxxxxxxxxxxxxx> wrote:
>> Sure make sense, I wasn't quite sure how to make this quite clear,
>> a naming convention seems good to me but I also had added at least
>> a print about this on the log. Ideally I think a TAIN_DEBUG would
>> be best and it seems it could be useful for many other cases in
>> the kernel, we could also just re-use TAINT_CRAP as well. Thoughts?
>> Greg?
> TAINT_CRAP is for drivers/staging/ code, don't try to repurpose it for
> some other horrid option. There's no reason we can't add more taint
> flags for this.

OK thanks, I'll add TAINT_DEBUG. Any preference where to stuff struct
driver_attach_work *attach_work ? On the private data structure as
this patch currently implements, saving us 24 bytes and hiding it from
drivers, or stuffing it on the device driver and simplifying the core

To unsubscribe from this list: send the line "unsubscribe linux-kernel" in
the body of a message to majordomo@xxxxxxxxxxxxxxx
More majordomo info at
Please read the FAQ at