Re: [PATCH v6 2/4] i2c: add support for Diolan DLN-2 USB-I2C adapter

From: Johan Hovold
Date: Wed Oct 08 2014 - 06:45:16 EST


On Thu, Sep 25, 2014 at 07:07:32PM +0300, Octavian Purdila wrote:

> diff --git a/Documentation/ABI/testing/sysfs-bus-i2c-busses-dln2 b/Documentation/ABI/testing/sysfs-bus-i2c-busses-dln2
> new file mode 100644
> index 0000000..ad55af6
> --- /dev/null
> +++ b/Documentation/ABI/testing/sysfs-bus-i2c-busses-dln2

This is a nonstandard path that does not match the attribute path (or
any other convention followed under ABI/).

I suggest you rename it

sysfs-class-i2c-adapter-dln2

> @@ -0,0 +1,5 @@
> +What: /sys/bus/i2c/devices/.../dln2_i2c_freq

I think you should rename the attribute "bus_frequency" and name the
attribute group "dln2". That way the attribute will show up as

.../<device>/dln2/bus_frequency

Then the "What:" field should read

What: /sys/class/i2c-adapter/<device>/dln2/bus_frequency

> +Date: September 2014
> +Contact: Octavian Purdila <octavian.purdila@xxxxxxxxx>
> +Description:
> + This attribute shows/sets the frequency (in Hz) of the I2C bus.

I'd reword this "Set the frequency...".

Please also describe under what circumstances this may fail, that is,
when setting a frequency less than or greater than the min or max
frequencies reported by the device.

Perhaps you should even consider exporting those two values?

Johan
--
To unsubscribe from this list: send the line "unsubscribe linux-kernel" in
the body of a message to majordomo@xxxxxxxxxxxxxxx
More majordomo info at http://vger.kernel.org/majordomo-info.html
Please read the FAQ at http://www.tux.org/lkml/