On Wed, Nov 05, 2014 at 04:47:14PM +0100, Maxime Coquelin wrote:
On 11/05/2014 12:10 PM, Rasmus Villemoes wrote:I'm fine with that, feel free to post another version and I'll replace
On Tue, Nov 04 2014, Maxime COQUELIN <maxime.coquelin@xxxxxx> wrote:That's a good point.
-#define GENMASK(h, l) (((U32_C(1) << ((h) - (l) + 1)) - 1) << (l))Slightly bikeshedding here, but may I suggest spelling it
-#define GENMASK_ULL(h, l) (((U64_C(1) << ((h) - (l) + 1)) - 1) << (l))
+#define GENMASK(h, l) \
+ ((~0UL >> (BITS_PER_LONG - ((h) - (l) + 1))) << (l))
+
+#define GENMASK_ULL(h, l) \
+ ((~0ULL >> (BITS_PER_LONG_LONG - ((h) - (l) + 1))) << (l))
(((~0UL) << (l)) & (~0UL >> (BITS_PER_LONG - 1 - (h))))
? This will ensure the arguments are expanded once each, and will, IMHO,
DTRT if/when l > h (namely, yield 0).
Peter, what is your view?
v3.