Re: [patch 07/16] genirq: Introduce helper irq_domain_set_info() to reduce duplicated code

From: Jiang Liu
Date: Thu Nov 13 2014 - 05:00:48 EST


On 2014/11/13 17:57, Yingjoe Chen wrote:
> On Wed, 2014-11-12 at 13:43 +0000, Thomas Gleixner wrote:
>> Index: tip/kernel/irq/irqdomain.c
>> ===================================================================
>> --- tip.orig/kernel/irq/irqdomain.c
>> +++ tip/kernel/irq/irqdomain.c
>> @@ -882,6 +882,16 @@ int irq_domain_set_hwirq_and_chip(struct
>> return 0;
>> }
>>
>> +void irq_domain_set_info(struct irq_domain *domain, unsigned int virq,
>> + irq_hw_number_t hwirq, struct irq_chip *chip,
>> + void *chip_data, irq_flow_handler_t handler,
>> + void *handler_data, const char *handler_name)
>> +{
>> + irq_domain_set_hwirq_and_chip(domain, virq, hwirq, chip, chip_data);
>> + __irq_set_handler(virq, handler, 0, handler_name);
>> + irq_set_handler_data(virq, handler_data);
>> +}
>> +
>
> Hi,
>
> While trying to use this function, I'm not sure about its interface.
> This function have 8 parameters but only save 3 function calls. After
> checking uses in Jiang's original patch, I think this make code harder
> to understand.
Hi Joe,
It's true, but we also want to reduce duplicated code:(
Regards!
Gerry
>
> --
> To unsubscribe from this list: send the line "unsubscribe linux-kernel" in
> the body of a message to majordomo@xxxxxxxxxxxxxxx
> More majordomo info at http://vger.kernel.org/majordomo-info.html
> Please read the FAQ at http://www.tux.org/lkml/
>
--
To unsubscribe from this list: send the line "unsubscribe linux-kernel" in
the body of a message to majordomo@xxxxxxxxxxxxxxx
More majordomo info at http://vger.kernel.org/majordomo-info.html
Please read the FAQ at http://www.tux.org/lkml/