perf kernel module symbols

From: Martin Sherburn
Date: Wed Feb 18 2015 - 09:27:47 EST


Iâm having some trouble getting perf to load symbols for my kernel
module. If I do a system wide capture for example with âperf record -g
fp -a sleep 15â followed by âperf report | headâ it tells me the

No kallsyms or vmlinux with build-id
3b4704f9bcec1645cd1041286dd5125af061ca95 was found
[mymodule] with build id 3b4704f9bcec1645cd1041286dd5125af061ca95 not
found, continuing without symbols

The module does show up in the list when I do âperf buildid-listâ,
however it is not present in â~/.debug/.build-idâ. I tried to manually
add it with âperf buildid-cache -a /lib/modules/`uname
-r`/extra/mymoduleâ. However then when I do âperf reportâ I get a
Segmentation fault.

I did manage to partly work-around the issue by typing âperf report
âsymfs=/â. I still get the error âbuild id not found, continuing
without symbolsâ but the symbols do get resolved correctly as I can
see function names rather than just hex addresses in the report. But I
still cannot annotate functions, I get the following error:

objdump: '[mymodule]': No such file

If I statically link my driver into the kernel instead of using
modules then everything works fine, however Iâd rather not do this. I
am using perf version 3.10.40-ltsi. Any help regarding this issue
would be greatly appreciated.


To unsubscribe from this list: send the line "unsubscribe linux-kernel" in
the body of a message to majordomo@xxxxxxxxxxxxxxx
More majordomo info at
Please read the FAQ at