Re: [PATCH] fs/fat: remove fat12_ent_blocknr and use fat_ent_blocknr instead

From: OGAWA Hirofumi
Date: Wed Feb 18 2015 - 14:23:10 EST

Alexander Kuleshov <kuleshovmail@xxxxxxxxx> writes:

> There is only one difference between fat12_ent_blocknr and fat_ent_blocknr
> functions in bytes calculation. Let's add bits checking to fat_ent_blocknr
> instead code duplication.

I guess, fat12 (very small volume size) is uncommon to be used now, and
there is no way to switch fat12 <= fat16/fat32 at runtime. It is why has
special handler, i.e. avoid overhead to fat16/fat32 by fat12 code.

OGAWA Hirofumi <hirofumi@xxxxxxxxxxxxxxxxxx>
To unsubscribe from this list: send the line "unsubscribe linux-kernel" in
the body of a message to majordomo@xxxxxxxxxxxxxxx
More majordomo info at
Please read the FAQ at