"Unkillable processes" and INFO: task ... blocked for more than 120 seconds

From: Manuel Reimer
Date: Fri Feb 20 2015 - 12:13:58 EST


today, I had the following problem:

I was editing a few photos in GIMP and after I finished with that, I tried to close GIMP which failed. KDE offered me to terminate the application which also didn't work.

So I opened a terminal and tried "killall -9 gimp" --> No success

Next I tried "pgrep gimp" to get the PID of the hanging process. With the result that pgrep now also got stuck with hangup of my whole shell.

A "strace pgrep gimp" told me that pgrep actually hung up on a read on "/proc/18294/cmdline" so I guessed that this could be my hanging GIMP process. But even "kill -9 18294" was not able to kill the process.

So I switched over to a VT shell and logged in as root which at first hung up the login shell, but was fixable by pressing "Ctrl + C". Even as root I was unable to kill GIMP.

The kernel didn't actually crash. My music player continued to play nicely and my mail client was fully usable.

I saved some log output to pastebin: http://pastebin.com/FPDvyePJ

What has been happening here? Why is it possible that I actually get non-killable processes?

If you need additional information, please ask.

Thank you very much in advance.


To unsubscribe from this list: send the line "unsubscribe linux-kernel" in
the body of a message to majordomo@xxxxxxxxxxxxxxx
More majordomo info at http://vger.kernel.org/majordomo-info.html
Please read the FAQ at http://www.tux.org/lkml/