Re: "Unkillable processes" and INFO: task ... blocked for more than 120 seconds

From: Martin Steigerwald
Date: Fri Feb 20 2015 - 14:33:17 EST

Am Freitag, 20. Februar 2015, 18:30:29 schrieb Manuel Reimer:
> Hello,

Hello Manuel,

> On 02/20/2015 06:13 PM, Manuel Reimer wrote:
> > Hello,
> >
> > today, I had the following problem:
> >
> > I was editing a few photos in GIMP and after I finished with that, I
> > tried to close GIMP which failed. KDE offered me to terminate the
> > application which also didn't work.
> >
> > So I opened a terminal and tried "killall -9 gimp" --> No success
> >
> > Next I tried "pgrep gimp" to get the PID of the hanging process. With
> > the result that pgrep now also got stuck with hangup of my whole
> > shell.
> >
> > A "strace pgrep gimp" told me that pgrep actually hung up on a read on
> > "/proc/18294/cmdline" so I guessed that this could be my hanging GIMP
> > process. But even "kill -9 18294" was not able to kill the process.
> >
> > So I switched over to a VT shell and logged in as root which at first
> > hung up the login shell, but was fixable by pressing "Ctrl + C". Even
> > as root I was unable to kill GIMP.
> >
> > The kernel didn't actually crash. My music player continued to play
> > nicely and my mail client was fully usable.
> >
> > I saved some log output to pastebin:
> >
> > What has been happening here? Why is it possible that I actually get
> > non-killable processes?
> >
> > If you need additional information, please ask.
> >
> > Thank you very much in advance.

> I can add that this problem seems to be reproducible for me so either
> some change in one of the latest kernel updates caused this or something
> on my system hardware is starting to fail...
> If I open "a few" photos on GIMP (enough to get the application memory
> usage above 40%) then I'm able to close GIMP without any problems but it
> seems to get stuck in exactly the same way as it happened the first
> time.
> My system kernel: Linux manuelspc 3.18.6-1-ARCH #1 SMP PREEMPT Sat Feb 7
> 08:44:05 CET 2015 x86_64 GNU/Linux

Processes will be unkillable in Linux for as long as they remain in D
state (uninteruptible sleep). I suggest you read upon that topic.

ps aux | head -1 ; ps aux | grep "[g]imp"

should tell you whether thats the case.

In that case, there may be hints in kernel log about a task hung for more
than 120 seconds.

As to the reason? The process is stuck in a system function, usually I/O.

It can also happen on filesystem bugs.

If the process is not in D state, but still unkillable that would need
further exploration. Well zombie processes are unkillable as well then
there isnÂt a real process anymore either just its structure. Well that
would be the Z state.

Whether its such a hot idea to have unkillable processes, wellâ thats the
way it currently is in Linux (and I think quite some other Unix like
operating systems).

Martin 'Helios' Steigerwald -
GPG: 03B0 0D6C 0040 0710 4AFA B82F 991B EAAC A599 84C7
To unsubscribe from this list: send the line "unsubscribe linux-kernel" in
the body of a message to majordomo@xxxxxxxxxxxxxxx
More majordomo info at
Please read the FAQ at