Re: [PATCH v3 1/4] util_macros.h: add find_closest() macro

From: Bartosz Golaszewski
Date: Thu Mar 19 2015 - 12:28:53 EST

2015-03-19 17:03 GMT+01:00 Steven Rostedt <rostedt@xxxxxxxxxxx>:
> The above variables are not very unique. I've been thinking about all
> the variables that are defined in macros, and we may want to establish
> some kind of naming convention to keep from having name space
> collisions.
> Maybe something like...
> typeof(as) __fc_i_, __fc_a_ = (as) -1;
> typeof(__fc_x_) = (x);
> typeof(*a) *__fc_a_ = (a);
> -- Steve

Definitely a good idea - it should probably be added to section 12 of
the CodingStyle doc. What does 'fc' stand for?

To unsubscribe from this list: send the line "unsubscribe linux-kernel" in
the body of a message to majordomo@xxxxxxxxxxxxxxx
More majordomo info at
Please read the FAQ at