Re: [PATCH] x86/xsave: Robustify and merge macros

From: Quentin Casasnovas
Date: Fri Apr 03 2015 - 13:31:33 EST


On Fri, Apr 03, 2015 at 07:06:25PM +0200, Borislav Petkov wrote:
> On Fri, Apr 03, 2015 at 05:40:55PM +0200, Quentin Casasnovas wrote:
> > So yeah I still think we're not properly padding, if you take my earlier
> > example where repl2 = 5 bytes, repl1 = 4 bytes and orin_insn = 3.
> >
> > I'll let you re-read my original mail and come back to me to tell me what'd
> > I really miss! :)
>
> Dammit, dammit, dammit!
>
> And I thought this aspect was taken care of. I went into the old
> branches where I had done this and there I have:
>
> +#define OLDINSTR_2(oldinstr, num1, num2) \
> + __OLDINSTR(oldinstr, num1) \
> + ".skip -(((" alt_rlen(num2) ")-(" alt_rlen(num1) ")) > 0) * " \
> + "((" alt_rlen(num2) ")-(" alt_rlen(num1) ")),0x90\n" \
> + alt_end_marker ":\n"
> +
>
> without the size of the orig_insn factored in into the padding.
>
> And that would work for your example because it would add 1+1 bytes
> padding.
>
> Basically, the idea was:
>
> .skip len(repl1) - len(orig), 0x90
> .skip len(repl2) - len(repl1), 0x90
>
> BUT!, for some reason I changed it to what's there now and I can't
> remember why anymore.

I think it would not work in the case where repl1 is smaller or equal than
orig_insn (i.e. no padding in the first .skip) but orig_insn is strictly
smaller than repl2 (since we're never comparing repl2 with insn in this
new-old code).

Anything wrong with the two different approaches I've suggested in my
original mail? One is using a one-liner .skip directive inspired by yours,
and the other is using .if directives. FWIW I think exploding the logic
using conditionnals '.if' is way more readable and less error-prone.

Quentin
--
To unsubscribe from this list: send the line "unsubscribe linux-kernel" in
the body of a message to majordomo@xxxxxxxxxxxxxxx
More majordomo info at http://vger.kernel.org/majordomo-info.html
Please read the FAQ at http://www.tux.org/lkml/