Re: [PATCH v2 10/21] staging: rtl8192e: replace memcpy() -> ether_addr_copy_unaligned()

From: Mateusz Kulikowski
Date: Wed Apr 15 2015 - 17:08:50 EST


On 14.04.2015 10:00, Dan Carpenter wrote:
> BAReq->addr1 is part of struct rtllib_hdr_2addr. It's 4 bytes into
> the struct so it's fine.
You're right - should I explicitly add __aligned() in such places or just
leave comment in that case (for future commiters)?

> I sort of like the ether_addr_copy_unaligned() macro because it would
> let us silence some checkpatch false positives because otherwise people
> will eventually introduce bugs like a dripping roof leak will eventually
> destroy a building. But it should be in the main kernel header with a
> name like that. And also this is misleading that we are using it for
> data which is aligned.

Is it ok if I do following steps for v3:
- Align eth addresses that can be aligned (at least one structure - rtllib_rxb can't be aligned)
- Apply eth_addr_copy where possible
- Discuss and try to submit ether_addr_copy_unaligned on netdev list
- If they reject the change - rename macro to something less confusing (rtllib_something)

Regards and thanks for reviews,
Mateusz

--
To unsubscribe from this list: send the line "unsubscribe linux-kernel" in
the body of a message to majordomo@xxxxxxxxxxxxxxx
More majordomo info at http://vger.kernel.org/majordomo-info.html
Please read the FAQ at http://www.tux.org/lkml/