On Wed, Apr 15, 2015 at 04:01:35PM -0600, Jens Axboe wrote:
Hi,
A proper patch series posting of the patch to skip inode dio counts
where we don't need them. Performance results and general notes in
patch #1. We can take this a bit further if we want to push this
truncate locking into the caller, but I'd like to keep that as a
separate patch series instead.
Changes since v2:
- Changed flag to DIO_SKIP_DIO_COUNT. Patch 2+3 will use this for
skipping the extra inc/dec for btrfs and ext4, so better rename it
to something that better tells what is happening in the deep mess
that is dio.
- Have inode_dio_inc/dec() helpers. Again, this better tells the caller
what is going on.
Please, rebase on vfs.git#for-next; it conflicts (at least) with Omar's
->direct_IO() patches, if not with generic_write_checks() ones following
those.