On Mon, Apr 20, 2015 at 10:51:58AM -0500, Tom Tucker wrote:
On 4/20/15 10:16 AM, Michael Wang wrote:No, it says this code is concerned with the unique parts of iWarp
On 04/20/2015 04:00 PM, Steve Wise wrote:It's more consistent, but not necessarily more readable -- if by
On 4/20/2015 3:40 AM, Michael Wang wrote:[snip]
Sean suggested to add this helper paired with cap_ib_cm(), may be there arediff --git a/include/rdma/ib_verbs.h b/include/rdma/ib_verbs.hiWARP devices _must_ support the IWCM so cap_iw_cm() is not really useful.
index 6805e3e..e4999f6 100644
+++ b/include/rdma/ib_verbs.h
@@ -1818,6 +1818,21 @@ static inline int cap_ib_cm(struct ib_device *device, u8 port_num)
return rdma_ib_or_iboe(device, port_num);
}
+/**
+ * cap_iw_cm - Check if the port of device has the capability IWARP
+ * Communication Manager.
+ *
+ * @device: Device to be checked
+ * @port_num: Port number of the device
+ *
+ * Return 0 when port of the device don't support IWARP
+ * Communication Manager.
+ */
+static inline int cap_iw_cm(struct ib_device *device, u8 port_num)
+{
+ return rdma_tech_iwarp(device, port_num);
+}
+
int ib_query_gid(struct ib_device *device,
u8 port_num, int index, union ib_gid *gid);
some consideration on maintainability?
Me too also prefer this way to make the code more readable ;-)
readability we mean understanding.
If the reader knows how the transports work, then the reader would
be confused by the addition of a check that is always true. For the
reader that doesn't know, the addition of the check implies that the
support is optional, which it is not.
related to CM, not the other unique parts of iWarp. The check isn't
aways true, it is just always true on iWarp devices.
That became the problem with the old way of just saying 'is iWarp'
(and others). There are too many differences, the why became lost in
many places.
There are now too many standards, and several do not have public docs,
to keep relying on a mess of 'is standard' tests.
Jason
--
To unsubscribe from this list: send the line "unsubscribe linux-rdma" in
the body of a message to majordomo@xxxxxxxxxxxxxxx
More majordomo info at http://vger.kernel.org/majordomo-info.html