Re: [PATCH 2/2] kprobes/x86: Use 16 bytes for each instruction slot again

From: Ingo Molnar
Date: Wed Jun 03 2015 - 03:28:42 EST



* Masami Hiramatsu <masami.hiramatsu.pt@xxxxxxxxxxx> wrote:

> On 2015/06/02 14:44, Ingo Molnar wrote:
> >
> > * Masami Hiramatsu <masami.hiramatsu.pt@xxxxxxxxxxx> wrote:
> >
> >> On 2015/06/02 2:04, Andy Lutomirski wrote:
> >>> On Mon, Jun 1, 2015 at 9:32 AM, Eugene Shatokhin
> >>> <eugene.shatokhin@xxxxxxxxxx> wrote:
> >>>> Commit 91e5ed49fca0 ("x86/asm/decoder: Fix and enforce max instruction
> >>>> size in the insn decoder") has changed MAX_INSN_SIZE from 16 to 15 bytes
> >>>> on x86.
> >>>>
> >>>> As a side effect, the slots Kprobes use to store the instructions became
> >>>> 1 byte shorter. This is unfortunate because, for example, the Kprobes'
> >>>> "boost" feature can not be used now for the instructions of length 11,
> >>>> like a quite common kind of MOV:
> >>>> * movq $0xffffffffffffffff,-0x3fe8(%rax) (48 c7 80 18 c0 ff ff ff ff ff ff)
> >>>> * movq $0x0,0x88(%rdi) (48 c7 87 88 00 00 00 00 00 00 00)
> >>>> and so on.
> >>>>
> >>>> This patch makes the insn slots 16 bytes long, like they were before while
> >>>> keeping MAX_INSN_SIZE intact.
> >>>>
> >>>> Other tools may benefit from this change as well.
> >>>
> >>> What is a "slot" and why does this patch make sense? Naively, I'd
> >>> expect that the check you're patching is entirely unnecessary -- I
> >>> don't see what the size of the instruction being probed has to do with
> >>> the safety of executing it out of line and then jumping back.
> >>>
> >>> Is there another magic 16 somewhere that this is enforcing that we
> >>> don't overrun?
> >>
> >> The kprobe-"booster" adds a jump back code (jmp <probed address + insn length>)
> >> right after the instruction in the out-of-code buffer(slot). So we need at least
> >> the insn-length + 5 bytes for the slot, it's the trick of the magic :)
> >
> > Please at minimum rename it to 'dynamic code buffer' or some other sensible
> > name - the name 'slot' is pretty meaningless at best and misleading at worst.
>
> OK, would 'exec_buffer' is sensible? or just a 'code_buffer' is better?

Yeah, 'code buffer' sounds good to me.

Thanks,

Ingo
--
To unsubscribe from this list: send the line "unsubscribe linux-kernel" in
the body of a message to majordomo@xxxxxxxxxxxxxxx
More majordomo info at http://vger.kernel.org/majordomo-info.html
Please read the FAQ at http://www.tux.org/lkml/