Re: [PATCH 8/9] hrtimer: Allow hrtimer::function() to free the timer

From: Ingo Molnar
Date: Thu Jun 04 2015 - 08:37:17 EST



* Peter Zijlstra <peterz@xxxxxxxxxxxxx> wrote:

> On Thu, Jun 04, 2015 at 07:59:30AM +0200, Ingo Molnar wrote:
>
> > > --- a/include/linux/hrtimer.h
> > > +++ b/include/linux/hrtimer.h
> > > @@ -123,8 +123,10 @@ struct hrtimer_sleeper {
> > >
> > > #ifdef CONFIG_64BIT
> > > # define HRTIMER_CLOCK_BASE_ALIGN 64
> > > +# define __timer_base_running(timer) timer->base->running
> > > #else
> > > # define HRTIMER_CLOCK_BASE_ALIGN 32
> > > +# define __timer_base_running(timer) timer->base->cpu_base->running
> > > #endif
> >
> > Please put it into the cpu_base on 64-bit as well: the base pointer is available
> > already on 64-bit so there should be no measurable performance difference, and
> > readability is a primary concern with all this code.
>
> That's an extra pointer chase for no reason :-(

Only if we otherwise don't dereference cpu_base - is that the case in the relevant
code paths?

If we already dereference cpu_base (say for the lock) and have its value loaded
then it's totally equivalent to chasing down it in base->.

Thanks,

Ingo
--
To unsubscribe from this list: send the line "unsubscribe linux-kernel" in
the body of a message to majordomo@xxxxxxxxxxxxxxx
More majordomo info at http://vger.kernel.org/majordomo-info.html
Please read the FAQ at http://www.tux.org/lkml/