Re: [Resend PATCH 1/1] kernel/gcov/fs.c: Use kzalloc for allocating one thing

From: Peter Oberparleiter
Date: Mon Jun 22 2015 - 10:13:15 EST


On 22.06.2015 15:24, Maninder Singh wrote:
> Use kzalloc rather than kcalloc(1.. for allocation
> of one thing.
>
> Signed-off-by: Maninder Singh <maninder1.s@xxxxxxxxxxx>
> Reviewed-by: Vaneet Narang <v.narang@xxxxxxxxxxx>
> ---
> kernel/gcov/fs.c | 2 +-
> 1 file changed, 1 insertion(+), 1 deletion(-)
>
> diff --git a/kernel/gcov/fs.c b/kernel/gcov/fs.c
> index edf67c4..b31701a 100644
> --- a/kernel/gcov/fs.c
> +++ b/kernel/gcov/fs.c
> @@ -437,7 +437,7 @@ static struct gcov_node *new_node(struct gcov_node *parent,
> if (!node)
> goto err_nomem;
> if (info) {
> - node->loaded_info = kcalloc(1, sizeof(struct gcov_info *),
> + node->loaded_info = kzalloc(sizeof(struct gcov_info *),

Using kcalloc makes it more obvious to readers that the entity being
allocated is in fact an array, even if it starts out with only one
element. This implicit bit of information would be lost when using
kzalloc. Therefore I'd like to keep the current version for better
readability.

> GFP_KERNEL);
> if (!node->loaded_info)
> goto err_nomem;
>

--
Peter Oberparleiter
Linux on z Systems Development - IBM Germany

--
To unsubscribe from this list: send the line "unsubscribe linux-kernel" in
Please read the FAQ at http://www.tux.org/lkml/