Re: [PATCH 1/1] mm: move ->mremap() from file_operations to vm_operations_struct

From: Kirill A. Shutemov
Date: Tue Jun 23 2015 - 14:20:38 EST


On Tue, Jun 23, 2015 at 08:02:51PM +0200, Oleg Nesterov wrote:
> vma->vm_ops->mremap() looks more natural and clean in move_vma(),
> and this way ->mremap() can have more users. Say, vdso.
>
> Signed-off-by: Oleg Nesterov <oleg@xxxxxxxxxx>
> ---
> fs/aio.c | 25 ++++++++++++++++---------
> include/linux/fs.h | 1 -
> include/linux/mm.h | 1 +
> mm/mremap.c | 4 ++--

Please, update Documentation/filesystems/Locking.

> 4 files changed, 19 insertions(+), 12 deletions(-)
>
> diff --git a/fs/aio.c b/fs/aio.c
> index 9bc1335..6fe662a 100644
> --- a/fs/aio.c
> +++ b/fs/aio.c
> @@ -308,15 +308,9 @@ static void aio_free_ring(struct kioctx *ctx)
> }
> }
>
> -static int aio_ring_mmap(struct file *file, struct vm_area_struct *vma)
> -{
> - vma->vm_flags |= VM_DONTEXPAND;
> - vma->vm_ops = &generic_file_vm_ops;
> - return 0;
> -}
> -
> -static int aio_ring_remap(struct file *file, struct vm_area_struct *vma)
> +static int aio_ring_remap(struct vm_area_struct *vma)

I guess aio_ring_mremap() would be a better name.

> {
> + struct file *file = vma->vm_file;
> struct mm_struct *mm = vma->vm_mm;
> struct kioctx_table *table;
> int i, res = -EINVAL;
--
Kirill A. Shutemov
--
To unsubscribe from this list: send the line "unsubscribe linux-kernel" in
the body of a message to majordomo@xxxxxxxxxxxxxxx
More majordomo info at http://vger.kernel.org/majordomo-info.html
Please read the FAQ at http://www.tux.org/lkml/