On Wed, Jul 01, 2015 at 03:05:45AM +0530, Sohny Thomas wrote:I did it so that its readable, will remove it if not required
why you are inserting new line here?
FIX 2 unnecessary braces found by checkpatch.pl
Signed-off-by: Sohny Thomas <sohnythomas@xxxxxxxx>
---
drivers/staging/unisys/virtpci/virtpci.c | 11 ++++++-----
1 file changed, 6 insertions(+), 5 deletions(-)
diff --git a/drivers/staging/unisys/virtpci/virtpci.c b/drivers/staging/unisys/virtpci/virtpci.c
index d5ad017..f3674de 100644
--- a/drivers/staging/unisys/virtpci/virtpci.c
+++ b/drivers/staging/unisys/virtpci/virtpci.c
@@ -190,9 +190,10 @@ static int write_vbus_chp_info(struct spar_vbus_channel_protocol *chan,
return -1;
off = sizeof(struct channel_header) + chan->hdr_info.chp_info_offset;
- if (chan->hdr_info.chp_info_offset == 0) {
+
+ if (chan->hdr_info.chp_info_offset == 0)
return -1;
- }
+
I did this so that the code is more readable and understandable, I checked and checkpatch didn't call this out , so its clean.
memcpy(((u8 *)(chan)) + off, info, sizeof(*info));No, now this will introduce a new checkpatch warning that "else is not
return 0;
}
@@ -484,10 +485,10 @@ static int delete_vhba(struct del_virt_guestpart *delparams)
i = virtpci_device_del(NULL /*no parent bus */, VIRTHBA_TYPE,
&scsi.wwnn, NULL);
- if (i) {
+ if (i)
return 1;
- }
- return 0;
+ else
+ return 0;
required after return". why did you introduce this "else"?
regards
sudip