Re: [PATCH] USB-mxuport: Delete an unnecessary check before the function call "release_firmware"

From: Johan Hovold
Date: Mon Jul 06 2015 - 06:33:11 EST


On Sun, Jun 28, 2015 at 03:09:00PM +0200, SF Markus Elfring wrote:
> From: Markus Elfring <elfring@xxxxxxxxxxxxxxxxxxxxx>
> Date: Sun, 28 Jun 2015 14:59:04 +0200
>
> The release_firmware() function tests whether its argument is NULL and then
> returns immediately. Thus the test around the call is not needed.
>
> This issue was detected by using the Coccinelle software.
>
> Signed-off-by: Markus Elfring <elfring@xxxxxxxxxxxxxxxxxxxxx>
> ---
> drivers/usb/serial/mxuport.c | 3 +--
> 1 file changed, 1 insertion(+), 2 deletions(-)
>
> diff --git a/drivers/usb/serial/mxuport.c b/drivers/usb/serial/mxuport.c
> index 460a406..92f7aee 100644
> --- a/drivers/usb/serial/mxuport.c
> +++ b/drivers/usb/serial/mxuport.c
> @@ -1101,8 +1101,7 @@ static int mxuport_probe(struct usb_serial *serial,
> */
> usb_set_serial_data(serial, (void *)id->driver_info);
> out:
> - if (fw_p)
> - release_firmware(fw_p);
> + release_firmware(fw_p);
> return err;
> }

You sent the exact same patch last year and it was rejected then as it
does not improve readability:

https://www.marc.info/?l=linux-usb&m=141682024201419&w=3

So I'll drop this one again.

Johan
--
To unsubscribe from this list: send the line "unsubscribe linux-kernel" in
the body of a message to majordomo@xxxxxxxxxxxxxxx
More majordomo info at http://vger.kernel.org/majordomo-info.html
Please read the FAQ at http://www.tux.org/lkml/