Re: [PATCH] power_supply: Adjust devm usage
From: Sebastian Reichel
Date: Fri Jul 24 2015 - 08:26:32 EST
Hi,
Thanks for the cleanup patch.
I have a couple of comments inlined.
> Subject: Re: [PATCH] power_supply: Adjust devm usage
Please make this "power_supply: bq24735: ...".
On Fri, Jul 24, 2015 at 05:28:13PM +0530, Vaishali Thakkar wrote:
> Use devm_kasprintf instead of kasprintf. Also, remove various
> gotos by direct returns and drop unneeded label err_free_name.
Please also use devm_power_supply_unregister() instead
of power_supply_unregister() to further simplify the driver.
> @@ -267,8 +267,9 @@ static int bq24735_charger_probe() {}
> [...]
Your patch is missing removal of the
kfree(charger->charger_desc.name) in bq24735_charger_remove().
-- Sebastian
Attachment:
signature.asc
Description: Digital signature