Re: [PATCH] coredump: Replace opencoded set_mask_bits()

From: Peter Zijlstra
Date: Fri Aug 07 2015 - 10:57:45 EST


On Fri, Aug 07, 2015 at 08:14:03PM +0530, Vineet Gupta wrote:

> See, I have such a cmpxchg loop in ARC code - originally from Peter :-)
> arch/arc/kernel/smp.c. @ipi_data_ptr is NOT atomic_t
>
> do {
> new = old = ACCESS_ONCE(*ipi_data_ptr);
> new |= 1U << msg;
> } while (cmpxchg(ipi_data_ptr, old, new) != old);
>

Well, you'll have atomic_or() real soon now.
--
To unsubscribe from this list: send the line "unsubscribe linux-kernel" in
the body of a message to majordomo@xxxxxxxxxxxxxxx
More majordomo info at http://vger.kernel.org/majordomo-info.html
Please read the FAQ at http://www.tux.org/lkml/