Re: [PATCH 0/3] zram: Replace pr_* with dev_*

From: Minchan Kim
Date: Fri Aug 07 2015 - 10:59:11 EST


On Fri, Aug 07, 2015 at 03:37:56PM +0900, Sergey Senozhatsky wrote:
> Hello Minchan,
>
> On (08/07/15 15:05), Minchan Kim wrote:
> [..]
> > > I'd prefer to leave the messages the way they are. Changing anything
> > > visible to user space (api, eror codes, error messages, etc.) is a
> > > very risky business. You change the format of error messages and it
> > > smells like a big NO-NO.
> > >
> > > 'zram: Cannot initialise lzo compressing backend'
> > > --> 'block zram0: Cannot initialise lzo compressing backend'
> > >
> > >
> > > And there are even more dramatic changes:
> > > "Cannot change max compression streams\n"
> > > --> "Cannot change max compression streams to %d\n"
> > >
> > > "Can't change algorithm for initialized device\n"
> > > --> "Can't change algorithm to %s for initialized device\n"
> > >
> > >
> > > People already can have scripts doing `grep "zram:"` on dmesg or
> > > whatever. We cannot change this anymore.
> > >
> > > This potentially breaks things in user space. So, I NACK the change
> > > set. Thanks.
> > >
> > > Minchan, any opinion?
> >
> > Note: I didn't read this patchset in detail so I might be wrong.
> >
> > When I read description, I couldn't see what's the benefit.
> > Please write it out.
>
> we now have errors like
> 'zram: Cannot initialise lzo compressing backend'
>
> and they will transform into
>
> 'block zram0: Cannot initialise lzo compressing backend'
>
> note the prefix 'zram:' became 'block zram0:'

It would be better because it's more clear if we can make several
blocks.

>
>
> and there are two patches (well, at least I quickly spotted only
> those) that change messages' text
>
> From: "Cannot change max compression streams\n"
> To: "Cannot change max compression streams to %d\n"

In this context, we don't need to say about max_comp_streams value.
It's just fail regardless of the number of max stream you passed.
Instead, it would be better to have prefix like above(ie, block zram0)
for clarification/consistency.

>
> where %d is a supplied max_comp_stream value
>
> From: "Can't change algorithm for initialized device\n"
> To: "Can't change algorithm to %s for initialized device\n"

It's okay but hope to have prefix "block zram0"

>
> where %s is a supplied compression algorithm name.
>
>
> as far as I can tell.

Thanks for the explain. Sergey!

I feel we should investigate all of error/log info places to make
them clear/consistent if we decide to go with this.

Thanks.
--
Kind regards,
Minchan Kim
--
To unsubscribe from this list: send the line "unsubscribe linux-kernel" in
the body of a message to majordomo@xxxxxxxxxxxxxxx
More majordomo info at http://vger.kernel.org/majordomo-info.html
Please read the FAQ at http://www.tux.org/lkml/