Re: [PATCH v2 2/2] mm: hugetlb: add VmHugetlbRSS: field in /proc/pid/status

From: Naoya Horiguchi
Date: Sun Aug 09 2015 - 20:49:17 EST


On Fri, Aug 07, 2015 at 03:55:37PM -0700, Andrew Morton wrote:
> On Fri, 7 Aug 2015 07:24:50 +0000 Naoya Horiguchi <n-horiguchi@xxxxxxxxxxxxx> wrote:
>
> > Currently there's no easy way to get per-process usage of hugetlb pages, which
> > is inconvenient because applications which use hugetlb typically want to control
> > their processes on the basis of how much memory (including hugetlb) they use.
> > So this patch simply provides easy access to the info via /proc/pid/status.
> >
> > This patch shouldn't change the OOM behavior (so hugetlb usage is ignored as
> > is now,) which I guess is fine until we have some strong reason to do it.
> >
>
> A procfs change triggers a documentation change. Always, please.
> Documentation/filesystems/proc.txt is the place.

OK, I'll do this.

> >
> > ...
> >
> > @@ -504,6 +519,9 @@ static inline spinlock_t *huge_pte_lockptr(struct hstate *h,
> > {
> > return &mm->page_table_lock;
> > }
> > +
> > +#define get_hugetlb_rss(mm) 0
> > +#define mod_hugetlb_rss(mm, value) do {} while (0)
>
> I don't think these have to be macros? inline functions are nicer in
> several ways: more readable, more likely to be documented, can prevent
> unused variable warnings.

Right, I'll use inline functions.

> > #endif /* CONFIG_HUGETLB_PAGE */
> >
> > static inline spinlock_t *huge_pte_lock(struct hstate *h,
> >
> > ...
> >
> > --- v4.2-rc4.orig/mm/memory.c
> > +++ v4.2-rc4/mm/memory.c
> > @@ -620,12 +620,12 @@ int __pte_alloc_kernel(pmd_t *pmd, unsigned long address)
> > return 0;
> > }
> >
> > -static inline void init_rss_vec(int *rss)
> > +inline void init_rss_vec(int *rss)
> > {
> > memset(rss, 0, sizeof(int) * NR_MM_COUNTERS);
> > }
> >
> > -static inline void add_mm_rss_vec(struct mm_struct *mm, int *rss)
> > +inline void add_mm_rss_vec(struct mm_struct *mm, int *rss)
> > {
> > int i;
>
> The inlines are a bit odd, but this does save ~10 bytes in memory.o for
> some reason.

so I'll keep going with this.

Thanks,
Naoya Horiguchi