Re: [PATCH] Staging: dgnc: Fixed line over 80 characters in dgnc_mgmt.c

From: Dan Carpenter
Date: Mon Aug 10 2015 - 05:41:47 EST


On Sun, Aug 09, 2015 at 06:15:36PM +0530, Bhaktipriya Shridhar wrote:
> Fixed coding style issue "warning line over 80 characters"
> detected by checkpatch.pl in dgnc_mgmt.c

No signed off by.

> ---
> drivers/staging/dgnc/dgnc_mgmt.c | 3 ++-
> 1 file changed, 2 insertions(+), 1 deletion(-)
>
> diff --git a/drivers/staging/dgnc/dgnc_mgmt.c b/drivers/staging/dgnc/dgnc_mgmt.c
> index b13318a..e8fd3da 100644
> --- a/drivers/staging/dgnc/dgnc_mgmt.c
> +++ b/drivers/staging/dgnc/dgnc_mgmt.c
> @@ -148,7 +148,8 @@ long dgnc_mgmt_ioctl(struct file *file, unsigned int cmd, unsigned long arg)
> di.info_bdstate = dgnc_Board[brd]->dpastatus;
> di.info_ioport = 0;
> di.info_physaddr = (ulong) dgnc_Board[brd]->membase;
> - di.info_physsize = (ulong) dgnc_Board[brd]->membase - dgnc_Board[brd]->membase_end;
> + di.info_physsize = (ulong) dgnc_Board[brd]->membase -
> + dgnc_Board[brd]->membase_end;

Better to align it like:

di.info_physsize = (ulong)dgnc_Board[brd]->membase -
dgnc_Board[brd]->membase_end;

But even better would be to rename brd to brd_idx and introduce a new
"struct dgnc_board *brd" variable and set:

brd = dgnc_Board[brd_idx];

Then replace ever reference to "dgnc_Board[brd]" with just "brd".

regards,
dan carpenter


--
To unsubscribe from this list: send the line "unsubscribe linux-kernel" in
the body of a message to majordomo@xxxxxxxxxxxxxxx
More majordomo info at http://vger.kernel.org/majordomo-info.html
Please read the FAQ at http://www.tux.org/lkml/