Re: [PATCH v2 5/5] KVM: refactor asynchronous vcpu ioctl dispatch

From: Christian Borntraeger
Date: Wed Aug 12 2015 - 16:03:16 EST


Am 05.08.2015 um 18:33 schrieb Radim KrÄmÃÅ:
> I find the switch easier to read and modify.

yes.

> Signed-off-by: Radim KrÄmÃÅ <rkrcmar@xxxxxxxxxx>
> ---
> v2: new
>
> virt/kvm/kvm_main.c | 9 ++++++---
> 1 file changed, 6 insertions(+), 3 deletions(-)
>
> diff --git a/virt/kvm/kvm_main.c b/virt/kvm/kvm_main.c
> index d7ffe6090520..71598554deed 100644
> --- a/virt/kvm/kvm_main.c
> +++ b/virt/kvm/kvm_main.c
> @@ -2252,12 +2252,15 @@ static long kvm_vcpu_ioctl(struct file *filp,
> * Special cases: vcpu ioctls that are asynchronous to vcpu execution,
> * so vcpu_load() would break it.
> */
> + switch (ioctl) {
> #if defined(CONFIG_S390) || defined(CONFIG_PPC) || defined(CONFIG_MIPS)
> - if (ioctl == KVM_S390_INTERRUPT || ioctl == KVM_S390_IRQ || ioctl == KVM_INTERRUPT)
> - return kvm_arch_vcpu_ioctl(filp, ioctl, arg);
> + case KVM_S390_INTERRUPT:
> + case KVM_S390_IRQ:
> + case KVM_INTERRUPT:

When you are it you might want to put the KVM_S390* withing CONFIG_S390 and
KVM_INTERRUPT within CONFIG_PPC || CONFIG_MIPS

This might speed up the switch statement for s390/ppc/mips a tiny bit. It will add
another ifdef, though. Paolo?



> #endif
> - if (ioctl == KVM_USER_EXIT)
> + case KVM_USER_EXIT:
> return kvm_arch_vcpu_ioctl(filp, ioctl, arg);
> + }
>
> r = vcpu_load(vcpu);
> if (r)
>

--
To unsubscribe from this list: send the line "unsubscribe linux-kernel" in
the body of a message to majordomo@xxxxxxxxxxxxxxx
More majordomo info at http://vger.kernel.org/majordomo-info.html
Please read the FAQ at http://www.tux.org/lkml/