Re: [PATCH] leds: leds-ipaq-micro: Use devm_led_classdev_register

From: Jacek Anaszewski
Date: Mon Sep 07 2015 - 03:53:29 EST

Hi Muhammad,

Please split coding style fixes to a separate patch and leave
only devm related changes here.

On 09/05/2015 09:55 PM, Muhammad Falak R Wani wrote:
Use of resource-managed function devm_led_classdev_register
instead of led_classdev_register is preferred, consequently
remove redundant function micro_leds_remove. Also some coding
style issues are fixed, only two remain, which are left alone
to aid better readability.

Signed-off-by: Muhammad Falak R Wani <falakreyaz@xxxxxxxxx>
drivers/leds/leds-ipaq-micro.c | 47 ++++++++++++++++++------------------------
1 file changed, 20 insertions(+), 27 deletions(-)


Best Regards,
Jacek Anaszewski
To unsubscribe from this list: send the line "unsubscribe linux-kernel" in
the body of a message to majordomo@xxxxxxxxxxxxxxx
More majordomo info at
Please read the FAQ at