Re: [4.2, Regression] Queued spinlocks cause major XFS performance regression

From: Linus Torvalds
Date: Mon Sep 07 2015 - 16:45:26 EST

On Sun, Sep 6, 2015 at 11:57 PM, Peter Zijlstra <peterz@xxxxxxxxxxxxx> wrote:
> Just to continue the argument for arguments sake, the function is named
> 'virt' (not paravirt) and tests the HYPERVISOR CPUID bit. How is that
> not appropriately named?

Well, I think right now one issue is that you can't avoid it, even
when you want pure "raw hardware" spinlocks.

I really think it should at the very least be inside CONFIG_PARAVIRT.
Because it *is* about helping the hypervisor, so really is about

So naming is misleading, I think, and the config option situation is
not great. If you act differently under virtualization than you do on
raw hardware, what would you call that? I'd call it "paravirt".

To unsubscribe from this list: send the line "unsubscribe linux-kernel" in
the body of a message to majordomo@xxxxxxxxxxxxxxx
More majordomo info at
Please read the FAQ at