Re: [PATCH v1] mm: hwpoison: adjust for new thp refcounting

From: Sasha Levin
Date: Fri Nov 06 2015 - 01:32:27 EST

On 11/06/2015 01:11 AM, Naoya Horiguchi wrote:
> In the new refcounting, we no longer use tail->_mapcount to keep tail's
> refcount, and thereby we can simplify get_hwpoison_page() and remove
> put_hwpoison_page() (by replacing with put_page()).

This is confusing for the reader (and some static analysis tools): this adds
put_page()s without corresponding get_page()s.

Could we instead macro put_hwpoison_page() as put_page() for the sake of readability?

To unsubscribe from this list: send the line "unsubscribe linux-kernel" in
the body of a message to majordomo@xxxxxxxxxxxxxxx
More majordomo info at
Please read the FAQ at